Solved

Create record in databases UNAVAILABLE (!)

  • 31 August 2023
  • 14 replies
  • 142 views

Userlevel 4
Badge +1

Hi, everyone.

The option to “Create record” in “databases” is UNAVAILABLE (!)

I need to create lot of record inside the databases today…
 

Help!

icon

Best answer by Leandro Almeida 5 September 2023, 01:20

View original

14 replies

Userlevel 7
Badge +9

Hi @lucas-nogueira-virtoseng!
Can you share more details about what happend when you try to create a record, please? I suggest you check if you have permission for this action.
Any error message? If possible, send us an image😉

Userlevel 4
Badge +1

Hi, @Lais Laudari 

I have permission! I did create all the databases of my company and I do it everyday.
Just today I saw this problem.

Could you check the prints that I did attached?

Userlevel 7
Badge +9

@lucas-nogueira-virtoseng can you, please open a chat with our support team?
They will be able to investigate what is happening to help you properly😀

 

Userlevel 4
Badge +1

Thanks for try, @Lais Laudari .

Unfortunately, there’s no option in support team to talk with someone (I tried all of them)
There’s just options to be send to other texts.

Userlevel 6
Badge +4

@lucas-nogueira-virtoseng whats up? 

I couldn't see how many fields there are in your database, apparently there aren't any. 

To check, go here: 

 

 

This option will appear: 

 

Please check if there are any fields, apparently there were, but they have been deleted. 

I can only see the title of the records that were there:
 


best regards! 

 

Userlevel 4
Badge +1

Hi, @leandro-almeida !
Thanks for your try!

That’s a one-column database.
There’s no other fields or form related.
It's got just tittle field.
I just need to add other tittles in this database, like a I always did.

*Today, after this issue, I put a ID field just to test if the problem could be solving.

Userlevel 4
Badge +1

People,

The thing is:
Now, Pipefy isn’t recognizing “Tittle” as a field in database.
We can’t add just “tittle” anymore in the form.

*and we got a big database with these tittles.

Userlevel 6
Badge +4

Hi @lucas-nogueira-virtoseng 

 

Eu gravei um vídeo, em português, pelo seu nome imagino que seja seu idioma, mas se não for e não compreender, me aviso, ok? 

 

 

Userlevel 4
Badge +1

Bom dia, @leandro-almeida !
Novamente, muito obrigado pela atenção.
(Estava perguntando em inglês na expectativa de ter mais alcance do problema haha)

Segue vídeo abaixo com mais detalhes, caso puder avaliar:

https://www.loom.com/share/f3ac554590ab4030beb34127371ee08c?sid=d2f67cd7-058d-4e73-8eb8-28167425a536

Abraço!

Userlevel 7
Badge +13

Não é recomendável usar nomes de campos com os mesmos nomes dos atributos já existentes.

E isso é um bug sim. Eu mesmo já fiz isso há muito tempo atrás e ocorreu o mesmo problema.  Como era algo novo que eu estava criando, eu apaguei tudo comecei do zero com novos nomes e deu tudo certo.

Userlevel 7
Badge +9

@leandro-almeida consegue nos confirmar se esta situação reportada pelo Lucas é mesmo bug? Se sim, já foi mapeado e direcionado ao time responsável? 

Userlevel 6
Badge +4

Bom dia @Lais Laudari @lucas-nogueira-virtoseng 

 

Estou verificando o que pode ter acontecido, quando tiver novidades eu aviso. 

 

Até mais!

Userlevel 6
Badge +4

Oi @lucas-nogueira-virtoseng 

 

Aparentemente não é um BUG, o time técnico não encontrou indícios de BUG, mas algumas coisas percebemos desse caso. Até o dia 31 de agosto, esse database, tinha um campo chamado: “Texto curto” Mas foi deletado nesse dia. 

Apesar de ter sido deletado, ele manteve as referência, ou seja: “Titulo”, como mantém outras referências que são atributos do Registro, como ''status'', ''criado em'', “atualizado em” Selecionando no botão de filtros: 

 

Se eu tiro esse filtro, o Pipe fica sem referência alguma: 

 

É como se fossem vestígios dos registros, foram criados em função do Campo que criou e deletou, mas eles podem permanecer sem o Campo e o valor que nele tinha 

Outra coisa que notei é que esse database do vídeo que me enviou, não havia nenhum usuário nele: “Pessoas: (0)”: 

 

Em fim, é um comportamento esperado de um database, quando tem um campo e tem o único campo (e seus registros nele) deletado. 

 

As referências permanecem, até que outro campo seja criado e outros registros sirvam de referência para o título, status, etc. 

 

Caso ainda tenha dúvida me da um toque, ok? 

Userlevel 4
Badge +1

Bom dia, @leandro-almeida .

“Até o dia 31 de agosto, esse database, tinha um campo chamado: “Texto curto” Mas foi deletado nesse dia.”
Havia citado no vídeo que criei e deletei no mesmo dia 31/08 como tentativa de solução pra adição de mais linhas.
Assim como minha primeira postagem nesse artigo foi em 31/08.

A solução a partir de então tem sido criar uma coluna adicional de texto curto para ter o título que preciso.

Porém, destaco que anteriormente 2 ou 3 databases só haviam a coluna de título, sem nunca terem sido criado outras colunas.
Era possível criar linhas apenas com título.


De qualquer forma, agradeço pelo tempo e atenção.
Acredito que não seja mais pertinente buscar outra solução para esta situação.

Reply